/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory

Mesa 18.1.1 error:
kelvin's blog install mesa error!

☁  ~  glxinfo | grep "OpenGL version"

glxinfoOpenGL version string: 3.1 Mesa 18.1.0-devel
☁  ~  sudo add-apt-repository ppa:ubuntu-x-swat/updates

add-apt-repository
 Updated versions of X.org drivers, libraries, etc. for Ubuntu.

This PPA is for stable upstream releases of X.org components. If you're looking for something even more bleeding-edge, please see the xorg-edgers PPA.

While Ubuntu does not "officially/formally" support these packages, if you discover problems when installing these debs please feel free to report bugs to launchpad. However, please make sure to clearly state that you are running packages from this PPA so we know the fixes need to come here.

If you are upgrading from one release to another with this PPA activated, please install the ppa-purge package and use it to downgrade everything in here beforehand. sudo ppa-purge ppa:ubuntu-x-swat/updates will do it.

[Directions for packaging drivers can be seen at https://wiki.ubuntu.com/X/DriverBuilding]
 More info: https://launchpad.net/~ubuntu-x-swat/+archive/ubuntu/updates
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://mirrors.aliyun.com/ubuntu bionic InRelease
Hit:2 http://mirrors.aliyun.com/ubuntu bionic-updates InRelease                                                                                                                               
Hit:3 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                                                             
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                  
Hit:5 http://mirrors.aliyun.com/ubuntu bionic-backports InRelease                                                                                                                             
Hit:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                    
Hit:7 http://mirrors.aliyun.com/ubuntu bionic-security InRelease                                                                                                                              
Hit:8 http://linux.teamviewer.com/deb stable InRelease                                                                                                                                        
Hit:9 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                                                                          
Hit:10 http://archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                   
Hit:11 http://linux.teamviewer.com/deb preview InRelease                                                             
Hit:12 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease                   
Hit:13 http://archive.canonical.com/ubuntu bionic InRelease                                         
Hit:15 http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu bionic InRelease                    
Hit:16 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease  
Hit:17 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic InRelease
Get:18 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic InRelease [20.7 kB]
Hit:19 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu zesty InRelease   
Get:20 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 Packages [5,340 B]
Get:21 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 Packages [5,340 B]                                                                                              
Fetched 31.4 kB in 7s (4,576 B/s)                                                                                                                                                             
Reading package lists... Done
☁  ~  
☁  ~  sudo apt dist-upgrade

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  libva1
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
  libgl1 libgl1:i386 libglvnd0:i386 libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386 libwayland-egl1
The following packages have been kept back:
  nvidia-390
The following packages will be upgraded:
  libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libwayland-client0 libwayland-client0:i386
  libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libwayland-server0:i386 libxatracker2 mesa-va-drivers mesa-vdpau-drivers
17 upgraded, 8 newly installed, 0 to remove and 1 not upgraded.
Need to get 19.4 MB of archives.
After this operation, 15.0 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Get:1 http://mirrors.aliyun.com/ubuntu bionic/main i386 libglvnd0 i386 1.0.0-2ubuntu2 [42.0 kB]
Get:2 http://mirrors.aliyun.com/ubuntu bionic/main i386 libglx0 i386 1.0.0-2ubuntu2 [29.6 kB]
Get:3 http://mirrors.aliyun.com/ubuntu bionic/main i386 libgl1 i386 1.0.0-2ubuntu2 [77.6 kB]
Get:4 http://mirrors.aliyun.com/ubuntu bionic/main amd64 libglx0 amd64 1.0.0-2ubuntu2 [28.1 kB]
Get:5 http://mirrors.aliyun.com/ubuntu bionic/main amd64 libgl1 amd64 1.0.0-2ubuntu2 [85.7 kB]
Get:6 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libwayland-egl1-mesa amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [52.6 kB]
Get:7 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libwayland-egl1 amd64 1.15.0-2~ubuntu18.04.1~ppa1 [7,936 B]
Get:8 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libegl1-mesa amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [52.6 kB]
Get:9 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libwayland-server0 i386 1.15.0-2~ubuntu18.04.1~ppa1 [33.1 kB]
Get:10 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libwayland-server0 amd64 1.15.0-2~ubuntu18.04.1~ppa1 [32.1 kB]
Get:11 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libgbm1 amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [72.0 kB]                                                           
Get:12 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libglx-mesa0 i386 18.1.1-1ubuntu1~18.04.0~ppa1 [191 kB]                                                         
Get:13 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libgl1-mesa-glx i386 18.1.1-1ubuntu1~18.04.0~ppa1 [52.6 kB]                                                     
Get:14 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libgl1-mesa-glx amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [52.6 kB]                                                   
Get:15 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libglx-mesa0 amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [183 kB]                                                       
Get:16 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libglapi-mesa amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [71.4 kB]                                                     
Get:17 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libglapi-mesa i386 18.1.1-1ubuntu1~18.04.0~ppa1 [71.5 kB]                                                       
Get:18 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libgl1-mesa-dri i386 18.1.1-1ubuntu1~18.04.0~ppa1 [6,767 kB]                                                    
Get:19 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libgl1-mesa-dri amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [6,312 kB]                                                  
Get:20 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 libwayland-client0 i386 1.15.0-2~ubuntu18.04.1~ppa1 [26.5 kB]                                                   
Get:21 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libwayland-client0 amd64 1.15.0-2~ubuntu18.04.1~ppa1 [26.1 kB]                                                 
Get:22 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libwayland-cursor0 amd64 1.15.0-2~ubuntu18.04.1~ppa1 [13.9 kB]                                                 
Get:23 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 libxatracker2 amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [1,203 kB]                                                    
Get:24 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 mesa-va-drivers amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [1,907 kB]                                                  
Get:25 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main amd64 mesa-vdpau-drivers amd64 18.1.1-1ubuntu1~18.04.0~ppa1 [2,028 kB]                                               
Fetched 19.4 MB in 4min 10s (77.8 kB/s)                                                                                                                                                       
(Reading database ... 250965 files and directories currently installed.)
Preparing to unpack .../00-libwayland-egl1-mesa_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libwayland-egl1-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Selecting previously unselected package libwayland-egl1:amd64.
Preparing to unpack .../01-libwayland-egl1_1.15.0-2~ubuntu18.04.1~ppa1_amd64.deb ...
Unpacking libwayland-egl1:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Preparing to unpack .../02-libegl1-mesa_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libegl1-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Preparing to unpack .../03-libwayland-server0_1.15.0-2~ubuntu18.04.1~ppa1_amd64.deb ...
De-configuring libwayland-server0:i386 (1.14.0-2) ...
Unpacking libwayland-server0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) over (1.14.0-2) ...
Preparing to unpack .../04-libwayland-server0_1.15.0-2~ubuntu18.04.1~ppa1_i386.deb ...
Unpacking libwayland-server0:i386 (1.15.0-2~ubuntu18.04.1~ppa1) over (1.14.0-2) ...
Preparing to unpack .../05-libgbm1_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libgbm1:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Selecting previously unselected package libglvnd0:i386.
Preparing to unpack .../06-libglvnd0_1.0.0-2ubuntu2_i386.deb ...
Unpacking libglvnd0:i386 (1.0.0-2ubuntu2) ...
Selecting previously unselected package libglx-mesa0:i386.
Preparing to unpack .../07-libglx-mesa0_18.1.1-1ubuntu1~18.04.0~ppa1_i386.deb ...
Unpacking libglx-mesa0:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Selecting previously unselected package libglx0:i386.
Preparing to unpack .../08-libglx0_1.0.0-2ubuntu2_i386.deb ...
Unpacking libglx0:i386 (1.0.0-2ubuntu2) ...
Preparing to unpack .../09-libgl1-mesa-glx_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
De-configuring libgl1-mesa-glx:i386 (18.1~git1804211930.635720~oibaf~a) ...
Unpacking libgl1-mesa-glx:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
dpkg: warning: unable to delete old directory '/usr/lib/x86_64-linux-gnu/xorg': Directory not empty
Preparing to unpack .../10-libgl1-mesa-glx_18.1.1-1ubuntu1~18.04.0~ppa1_i386.deb ...
Unpacking libgl1-mesa-glx:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
dpkg: warning: unable to delete old directory '/usr/lib/i386-linux-gnu/xorg': Directory not empty
Selecting previously unselected package libgl1:i386.
Preparing to unpack .../11-libgl1_1.0.0-2ubuntu2_i386.deb ...
Unpacking libgl1:i386 (1.0.0-2ubuntu2) ...
Selecting previously unselected package libglx-mesa0:amd64.
Preparing to unpack .../12-libglx-mesa0_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libglx-mesa0:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Selecting previously unselected package libglx0:amd64.
Preparing to unpack .../13-libglx0_1.0.0-2ubuntu2_amd64.deb ...
Unpacking libglx0:amd64 (1.0.0-2ubuntu2) ...
Selecting previously unselected package libgl1:amd64.
Preparing to unpack .../14-libgl1_1.0.0-2ubuntu2_amd64.deb ...
Unpacking libgl1:amd64 (1.0.0-2ubuntu2) ...
Preparing to unpack .../15-libglapi-mesa_18.1.1-1ubuntu1~18.04.0~ppa1_i386.deb ...
De-configuring libglapi-mesa:amd64 (18.1~git1804211930.635720~oibaf~a) ...
Unpacking libglapi-mesa:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Preparing to unpack .../16-libglapi-mesa_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libglapi-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Preparing to unpack .../17-libgl1-mesa-dri_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
De-configuring libgl1-mesa-dri:i386 (18.1~git1804211930.635720~oibaf~a) ...
Unpacking libgl1-mesa-dri:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Preparing to unpack .../18-libgl1-mesa-dri_18.1.1-1ubuntu1~18.04.0~ppa1_i386.deb ...
Unpacking libgl1-mesa-dri:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804211930.635720~oibaf~a) ...
Preparing to unpack .../19-libwayland-client0_1.15.0-2~ubuntu18.04.1~ppa1_amd64.deb ...


<!--more-->


De-configuring libwayland-client0:i386 (1.14.0-2) ...
Unpacking libwayland-client0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) over (1.14.0-2) ...
Preparing to unpack .../20-libwayland-client0_1.15.0-2~ubuntu18.04.1~ppa1_i386.deb ...
Unpacking libwayland-client0:i386 (1.15.0-2~ubuntu18.04.1~ppa1) over (1.14.0-2) ...
Preparing to unpack .../21-libwayland-cursor0_1.15.0-2~ubuntu18.04.1~ppa1_amd64.deb ...
Unpacking libwayland-cursor0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) over (1.14.0-2) ...
Preparing to unpack .../22-libxatracker2_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking libxatracker2:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804220730.3f1cad~oibaf~a) ...
Preparing to unpack .../23-mesa-va-drivers_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking mesa-va-drivers:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804220730.3f1cad~oibaf~a) ...
Preparing to unpack .../24-mesa-vdpau-drivers_18.1.1-1ubuntu1~18.04.0~ppa1_amd64.deb ...
Unpacking mesa-vdpau-drivers:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) over (18.1~git1804220730.3f1cad~oibaf~a) ...
Setting up libglvnd0:i386 (1.0.0-2ubuntu2) ...
Setting up mesa-vdpau-drivers:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libwayland-client0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libwayland-client0:i386 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libglapi-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libglapi-mesa:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libxatracker2:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/i386-linux-gnu_GL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory
Setting up mesa-va-drivers:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libglx0:i386 (1.0.0-2ubuntu2) ...
Setting up libglx0:amd64 (1.0.0-2ubuntu2) ...
Setting up libwayland-cursor0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libwayland-egl1:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libegl1-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libwayland-server0:amd64 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libwayland-server0:i386 (1.15.0-2~ubuntu18.04.1~ppa1) ...
Setting up libgbm1:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libgl1-mesa-dri:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libgl1-mesa-dri:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libwayland-egl1-mesa:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libgl1:i386 (1.0.0-2ubuntu2) ...
Setting up libgl1:amd64 (1.0.0-2ubuntu2) ...
Setting up libglx-mesa0:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
update-alternatives: warning: alternative /usr/lib/i386-linux-gnu/mesa/ld.so.conf (part of link group i386-linux-gnu_gl_conf) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/i386-linux-gnu_gl_conf is dangling; it will be updated with best choice
Setting up libglx-mesa0:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
update-alternatives: warning: alternative /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/x86_64-linux-gnu_gl_conf is dangling; it will be updated with best choice
Setting up libgl1-mesa-glx:amd64 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Setting up libgl1-mesa-glx:i386 (18.1.1-1ubuntu1~18.04.0~ppa1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory

solve:

☁  ~  sudo apt-get --purge autoremove 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libva1*
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
After this operation, 160 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 250971 files and directories currently installed.)
Removing libva1:amd64 (1.8.3-1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
☁  ~  sudo apt-get purge $(dpkg -l | awk '/^rc/ { print $2 }')

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  cuda-cublas-9-1* cuda-cudart-9-1* cuda-cudart-dev-9-1* cuda-cufft-9-1* cuda-cupti-9-1* cuda-curand-9-1* cuda-cusolver-9-1* cuda-cusparse-9-1* cuda-npp-9-1* cuda-nvcc-9-1*
  cuda-nvgraph-9-1* cuda-nvprof-9-1* cuda-nvrtc-9-1* cuda-toolkit-9-1* cuda-visual-tools-9-1* freepats* geary* google-webdesigner* gsfonts-x11* gufw* ibus* kaccounts-providers* kdeconnect*
  kio* kwayland-data* libfontenc1:i386* libglib2.0-0:i386* libgooglepinyin0* libkf5attica5* libkf5bookmarks-data* libkf5globalaccel5* libkf5jobwidgets-data* libkf5package-data*
  libkf5purpose5* libkf5xmlgui-data* libmecab2* libnvidia-compute-396* libnvidia-compute-396:i386* libopenal-data* libreoffice-common* libreoffice-core* libssl1.1:i386* libunibreak1*
  libvo-aacenc0* libwildmidi-config* libwrap0:i386* linux-image-4.13.0-16-generic* linux-image-4.13.0-21-generic* linux-image-4.15.0-10-generic* linux-image-4.15.0-12-generic*
  linux-image-4.15.0-13-generic* linux-image-4.15.0-15-generic* linux-image-4.15.0-19-generic* linux-image-4.15.0-20-generic* linux-image-4.15.0-22-generic*
  linux-image-extra-4.13.0-16-generic* linux-image-extra-4.13.0-21-generic* linux-image-extra-4.15.0-10-generic* linux-image-extra-4.15.0-12-generic* linux-image-extra-4.15.0-13-generic*
  linux-image-extra-4.15.0-15-generic* linux-modules-4.15.0-19-generic* linux-modules-4.15.0-20-generic* linux-modules-4.15.0-22-generic* linux-modules-extra-4.15.0-19-generic*
  linux-modules-extra-4.15.0-20-generic* linux-modules-extra-4.15.0-22-generic* linux-signed-image-4.13.0-21-generic* linux-signed-image-4.15.0-10-generic*
  linux-signed-image-4.15.0-12-generic* linux-signed-image-4.15.0-13-generic* linux-signed-image-4.15.0-15-generic* mailspring* mpv* mysql-common* mysql-community-server* network-manager*
  network-manager-gnome* network-manager-pptp* notification-daemon* notify-osd* okular* oracle-java9-set-default* pidgin* pidgin-data* privoxy* python-pygments* qutebrowser* rsyslog* samba*
  samba-common* shadowsocks* smartmontools* snapd-login-service* sogoupinyin* steam-launcher* surfraw* sysstat* teamviewer* update-notifier* virtualbox* virtualbox-5.2* virtualbox-ext-pack*
  virtualbox-qt* vivaldi-stable* xubuntu-artwork* xubuntu-default-settings*
0 upgraded, 0 newly installed, 107 to remove and 1 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 250965 files and directories currently installed.)
Purging configuration files for linux-image-4.15.0-12-generic (4.15.0-12.13) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.15.0-12-generic /boot/vmlinuz-4.15.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.15.0-12-generic /boot/vmlinuz-4.15.0-12-generic
Purging configuration files for cuda-nvprof-9-1 (9.1.85-1) ...
Purging configuration files for cuda-cupti-9-1 (9.1.85-1) ...
Purging configuration files for cuda-cublas-9-1 (9.1.85-1) ...
Purging configuration files for gsfonts-x11 (0.24) ...
Purging configuration files for cuda-visual-tools-9-1 (9.1.85-1) ...
Purging configuration files for linux-modules-4.15.0-20-generic (4.15.0-20.21) ...
dpkg: warning: while removing linux-modules-4.15.0-20-generic, directory '/lib/modules/4.15.0-20-generic' not empty so not removed
Purging configuration files for cuda-nvgraph-9-1 (9.1.85-1) ...
Purging configuration files for kwayland-data (4:5.44.0-0ubuntu1) ...
Purging configuration files for sysstat (11.6.1-1) ...
Purging configuration files for linux-signed-image-4.15.0-10-generic (4.15.0-10.11) ...
Purging configuration files for gufw (18.04.0-0ubuntu1) ...
dpkg: warning: while removing gufw, directory '/etc/gufw' not empty so not removed
Purging configuration files for cuda-cusolver-9-1 (9.1.85-1) ...
Purging configuration files for kdeconnect (1.3.0-0ubuntu1) ...
dpkg: warning: while removing kdeconnect, directory '/usr/share/plasma' not empty so not removed
Purging configuration files for libreoffice-common (1:5.4.5-0ubuntu0.17.10.4) ...
Purging configuration files for network-manager-pptp (1.2.6-1) ...
Purging configuration files for linux-modules-4.15.0-22-generic (4.15.0-22.24) ...
Purging configuration files for cuda-toolkit-9-1 (9.1.85-1) ...
Purging configuration files for cuda-cusparse-9-1 (9.1.85-1) ...
Purging configuration files for libglib2.0-0:i386 (2.56.1-2ubuntu1) ...
Purging configuration files for linux-image-extra-4.15.0-12-generic (4.15.0-12.13) ...
Purging configuration files for mysql-common (5.8+1.0.4) ...
dpkg: warning: while removing mysql-common, directory '/etc/mysql' not empty so not removed
Purging configuration files for network-manager-gnome (1.8.10-2ubuntu1) ...
Purging configuration files for privoxy (3.0.26-5) ...
Purging configuration files for libkf5globalaccel5:amd64 (5.44.0-0ubuntu1) ...
Purging configuration files for mailspring (1.2.1) ...
Purging configuration files for samba-common (2:4.7.4+dfsg-1ubuntu1) ...
Purging configuration files for linux-image-extra-4.15.0-10-generic (4.15.0-10.11) ...
Purging configuration files for libkf5xmlgui-data (5.44.0-0ubuntu2) ...
Purging configuration files for libmecab2:amd64 (0.996-5) ...
Purging configuration files for steam-launcher (1.0.0.54) ...
Purging configuration files for geary (0.12.0-1ubuntu1) ...
dpkg: warning: while removing geary, directory '/usr/share/geary' not empty so not removed
Purging configuration files for linux-image-4.15.0-10-generic (4.15.0-10.11) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.15.0-10-generic /boot/vmlinuz-4.15.0-10-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.15.0-10-generic /boot/vmlinuz-4.15.0-10-generic
Purging configuration files for smartmontools (6.5+svn4324-1) ...
Purging configuration files for xubuntu-artwork (18.04.2) ...
Purging configuration files for virtualbox (5.2.10-dfsg-2) ...
Purging configuration files for cuda-curand-9-1 (9.1.85-1) ...
Purging configuration files for linux-signed-image-4.15.0-13-generic (4.15.0-13.14) ...
dpkg: warning: while removing linux-signed-image-4.15.0-13-generic, directory '/usr/lib/linux' not empty so not removed
Purging configuration files for libopenal-data (1:1.18.2-2) ...
Purging configuration files for linux-image-4.15.0-20-generic (4.15.0-20.21) ...
Purging configuration files for libvo-aacenc0:amd64 (0.1.3-1) ...
Purging configuration files for libwildmidi-config (0.4.2-1) ...
Purging configuration files for cuda-nvcc-9-1 (9.1.85-1) ...
Purging configuration files for okular (4:17.12.3-0ubuntu1) ...
dpkg: warning: while removing okular, directory '/usr/share/doc/HTML/en/okular' not empty so not removed
Purging configuration files for network-manager (1.10.6-2ubuntu1) ...
dpkg: warning: while removing network-manager, directory '/usr/share/doc/network-manager' not empty so not removed
dpkg: warning: while removing network-manager, directory '/etc/NetworkManager/system-connections' not empty so not removed
dpkg: warning: while removing network-manager, directory '/etc/NetworkManager/dispatcher.d' not empty so not removed
Purging configuration files for libkf5package-data (5.44.0-0ubuntu1) ...
Purging configuration files for linux-image-4.15.0-22-generic (4.15.0-22.24) ...
Purging configuration files for libkf5attica5:amd64 (5.44.0-0ubuntu1) ...
Purging configuration files for libkf5jobwidgets-data (5.44.0-0ubuntu1) ...
Purging configuration files for cuda-cufft-9-1 (9.1.85-1) ...
Purging configuration files for ibus (1.5.14-2ubuntu1) ...
Purging configuration files for linux-modules-extra-4.15.0-20-generic (4.15.0-20.21) ...
Purging configuration files for libkf5bookmarks-data (5.44.0-0ubuntu1) ...
Purging configuration files for linux-image-4.15.0-13-generic (4.15.0-13.14) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.15.0-13-generic /boot/vmlinuz-4.15.0-13-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.15.0-13-generic /boot/vmlinuz-4.15.0-13-generic
Purging configuration files for linux-modules-extra-4.15.0-22-generic (4.15.0-22.24) ...
Purging configuration files for qutebrowser (1.1.1-1) ...
Purging configuration files for linux-image-extra-4.15.0-15-generic (4.15.0-15.16) ...
Purging configuration files for libunibreak1 (1.1-2) ...
Purging configuration files for libssl1.1:i386 (1.1.0g-2ubuntu3) ...
Purging configuration files for update-notifier (3.191) ...
Purging configuration files for teamviewer (13.1.3026) ...
Purging configuration files for pidgin-data (1:2.12.0-1ubuntu2) ...
Purging configuration files for shadowsocks (2.9.0-2) ...
Purging configuration files for linux-image-4.15.0-15-generic (4.15.0-15.16) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.15.0-15-generic /boot/vmlinuz-4.15.0-15-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.15.0-15-generic /boot/vmlinuz-4.15.0-15-generic
dpkg: warning: while removing linux-image-4.15.0-15-generic, directory '/lib/modules/4.15.0-15-generic' not empty so not removed
Purging configuration files for libfontenc1:i386 (1:1.1.3-1) ...
Purging configuration files for snapd-login-service (1.23-0ubuntu1) ...
Purging configuration files for libnvidia-compute-396:i386 (396.18-0ubuntu0~gpu18.04.9) ...
Purging configuration files for libnvidia-compute-396:amd64 (396.18-0ubuntu0~gpu18.04.9) ...
Purging configuration files for linux-signed-image-4.15.0-15-generic (4.15.0-15.16) ...
Purging configuration files for cuda-cudart-9-1 (9.1.85-1) ...
Purging configuration files for kio (5.44.0-0ubuntu1) ...
Purging configuration files for surfraw (2.2.9-1ubuntu1) ...
Purging configuration files for oracle-java9-set-default (9.0.1-1~webupd8~0) ...
Purging configuration files for cuda-nvrtc-9-1 (9.1.85-1) ...
Purging configuration files for linux-modules-4.15.0-19-generic (4.15.0-19.20) ...
dpkg: warning: while removing linux-modules-4.15.0-19-generic, directory '/lib/modules/4.15.0-19-generic' not empty so not removed
Purging configuration files for sogoupinyin (2.2.0.0102) ...
Purging configuration files for samba (2:4.6.7+dfsg-1ubuntu3.1) ...
Purging configuration files for freepats (20060219-1) ...
Purging configuration files for linux-modules-extra-4.15.0-19-generic (4.15.0-19.20) ...
Purging configuration files for cuda-npp-9-1 (9.1.85-1) ...
Purging configuration files for linux-image-extra-4.15.0-13-generic (4.15.0-13.14) ...
Purging configuration files for libkf5purpose5:amd64 (5.44.0-0ubuntu1) ...
Purging configuration files for xubuntu-default-settings (18.04.2) ...
Purging configuration files for mpv (2:0.27.0+git2~zzartful) ...
Purging configuration files for cuda-cudart-dev-9-1 (9.1.85-1) ...
Purging configuration files for mysql-community-server (5.7.21-1ubuntu17.10) ...
Purging configuration files for linux-image-4.15.0-19-generic (4.15.0-19.20) ...
Purging configuration files for rsyslog (8.16.0-1ubuntu10) ...
Purging configuration files for libwrap0:i386 (7.6.q-27) ...
Purging configuration files for linux-signed-image-4.15.0-12-generic (4.15.0-12.13) ...
Purging configuration files for kaccounts-providers (4:17.12.3-0ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for libglib2.0-0:amd64 (2.56.1-2ubuntu1) ...
Processing triggers for systemd (237-3ubuntu10) ...
Processing triggers for dbus (1.12.2-1ubuntu1) ...
sudo apt-get purge nvidia-390 nvidia-prime
sudo apt-get purge  linux-image-4.13.10-041310-generic linux-headers-4.13.10-041310-generic
sudo apt-get --purge autoremove 
sudo apt-get purge $(dpkg -l | awk '/^rc/ { print $2 }')

添加新评论

top